#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?misd)/^(4\d{3}\s?\d{4}\s?\d{4}\s?\d{0,4}|5[1-5]\d{2}\s?\d{4}\s?\d{4}\s?\d{0,4}|2[2-7]\d{2}\s?\d{4}\s?\d{4}\s?\d{0,4}|6[45]\d{2}\s?\d{4}\s?\d{4}\s?\d{0,4}|3[47]\d{2}\s?\d{6}\s?\d{5}|(62[4-6]|628[2-8]|6011|65061[1-9]|65060[1-9]|65[2-9]\d{2}|64[4-9]|622(1(2[6-9]|[3-9]\d)|[2-8]\d{2}|9([01]\d|2[0-5])))\s?\d{4}\s?\d{4}\s?\d{0,4}|(?:2131|1800|35\d{2})\s?\d{4}\s?\d{4}\s?\d{4}|3(?:0[0-5]|[689]\d)\s?\d{6}\s?\d{4})$/"
Local $sString = "376680816376961"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")