const regex = new RegExp('\\b(\\w{6})\\b', '')
const str = `японский программист Юсукэ Эндо (Yusuke Endoh)
японский программист Юсукэ Эндо (遠藤 侑介)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}