package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(youtu.be\/|v\/|u\/\w\/|embed\/|watch\?v=|\&v=)([^#\&\?]*)(?:(\?t|&start)=(\d+))?.*`)
var str = `http://youtu.be/xxxxxxxx?t=30s
https://www.youtube.com/watch?v=xxxxxxxx&start=30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}