import re
regex = re.compile(r"<iframe[\s\w=\"\/]*src=\"(?<src>(?:https*:\/\/)?www\.youtube(?:-nocookie)?\.com\/embed\/(?<vid>[-a-zA-Z0-9@:;%_+.~#&=]+)\??(?<params>[-a-zA-Z0-9@:;%_+.~#?&\/=]*))\"[^>]*>(?:<\/iframe>)?$", flags=re.MULTILINE)
test_str = ("<iframe src=\"https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe src=\"https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe src=\"https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"440\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe src=\"https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe src=\"https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe src=\"https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe src=\"https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
"<iframe id=\"ytplayer\" type=\"text/html\" width=\"720\" height=\"405\" src=\"https://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&cc_load_policy=1&disablekb=1&enablejsapi=1&modestbranding=1&playsinline=1&rel=0&showinfo=0&color=white\"\n"
"frameborder=\"0\" allowfullscreen>\n\n"
"<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/Hb9-Bvne_gQ\" frameborder=\"0\" allow=\"autoplay; encrypted-media\" allowfullscreen></iframe>\n\n"
"<iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/Hb9-Bvne_gQ?rel=0\" frameborder=\"0\" allow=\"autoplay; encrypted-media\" allowfullscreen></iframe>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")