$re = '/^([_0-9a-zA-Z-]+\/)?(wp-(content|admin|includes).*)/m';
$str = 'wp-content/plugins/example.php
subsite1/wp-content/plugins/example.php
subsite2/wp-content/plugins/example.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);