$re = '/^(?=.*\d.*)[A-Za-z0-9]{3,10}$/';
$str = 'A12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);