use strict;
my $str = '<p>This is a test of a </p>
<p>long sentence that</p>
<p>should not be separated.</p>';
my $regex = qr/<\/p>\n\n<p>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";