// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a .*? style="text-decoration:none;color:#676c6c".*?>.*?<\/a>"#).unwrap();
let string = "<a href=\"http://SOME-RANDOM-LINK-HERE.com/\" style=\"text-decoration:none;color:#676c6c\">SOME RANDOM TEXT HERE</a>
<div id=\"something\">
This is something which wont be deleted.
</div>
<a href=\"something\" style=\"something\"> This should not be deleted </a>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}