import Foundation
let pattern = #"""
^
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(\d|[1-9]\d|1\d\d|2
([0-4]\d|5[0-5])
)
\.
(0|64|128|192)
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
172.17.251.64
172.17.251.200
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)