using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/folder1/statistics\/?(?:[^\/]+\/?)*$";
string input = @"folder1/statistics
folder1/statistics/test1
folder1/statistics/test1/test2
folder1/statistics/test1/test2/test3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}