// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^/folder1/statistics\/?(?:[^\/]+\/?)*$").unwrap();
let string = "folder1/statistics
folder1/statistics/test1
folder1/statistics/test1/test2
folder1/statistics/test1/test2/test3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}