#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:\w+\W+){0,20}(?:BADWORD1|BAD2)\b(?:\W+\w+){0,20}|\b(PRIMARY1|P2|P3)\b|\b(SECONDARY1|S2|S3)\W+(?:\w+\W+){0,20}(TERTIARY1|T2|T3)\b|\b(TERTIARY1|T2|T3)\W+(?:\w+\W+){0,20}(SECONDARY1|S2|S3)\b"
Local $sString = "word word word word word word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . ." & @CRLF & _
"" & @CRLF & _
"word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . ." & @CRLF & _
"" & @CRLF & _
"word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . ." & @CRLF & _
" " & @CRLF & _
"word word word word word word word word word word word word word word word word word word word word word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . ." & @CRLF & _
"" & @CRLF & _
"word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word word <MORE THAN 20 WORDS AWAY FROM BAD> word word word TERTIARY1 word word word word word word word word SECONDARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . ."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")