import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:\\w+\\W+){0,20}(?:BADWORD1|BAD2)\\b(?:\\W+\\w+){0,20}|\\b(PRIMARY1|P2|P3)\\b|\\b(SECONDARY1|S2|S3)\\W+(?:\\w+\\W+){0,20}(TERTIARY1|T2|T3)\\b|\\b(TERTIARY1|T2|T3)\\W+(?:\\w+\\W+){0,20}(SECONDARY1|S2|S3)\\b";
final String string = "word word word word word word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .\n\n"
+ "word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .\n\n"
+ "word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .\n"
+ " \n"
+ "word word word word word word word word word word word word word word word word word word word word word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .\n\n"
+ "word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word word <MORE THAN 20 WORDS AWAY FROM BAD> word word word TERTIARY1 word word word word word word word word SECONDARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}