const regex = new RegExp('\\b(?:\\w+\\W+){0,20}(?:BADWORD1|BAD2)\\b(?:\\W+\\w+){0,20}|\\b(PRIMARY1|P2|P3)\\b|\\b(SECONDARY1|S2|S3)\\W+(?:\\w+\\W+){0,20}(TERTIARY1|T2|T3)\\b|\\b(TERTIARY1|T2|T3)\\W+(?:\\w+\\W+){0,20}(SECONDARY1|S2|S3)\\b', 'gi')
const str = `word word word word word word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word word <MORE THAN 20 WORDS AWAY FROM BAD> word word word TERTIARY1 word word word word word word word word SECONDARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}