use strict;
my $str = 'word word word word word word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word PRIMARY1 . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word word word word word word word word word word SECONDARY1 word word word word word word word word TERTIARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .
word word word word word word word word word word word word word word word word word word word word word BADWORD1 word word word word word word word word word word word <MORE THAN 20 WORDS AWAY FROM BAD> word word word TERTIARY1 word word word word word word word word SECONDARY1. . . . . . . . . . . . . . . . . . . . . . . . . . . .';
my $regex = qr/\b(?:\w+\W+){0,20}(?:BADWORD1|BAD2)\b(?:\W+\w+){0,20}|\b(PRIMARY1|P2|P3)\b|\b(SECONDARY1|S2|S3)\W+(?:\w+\W+){0,20}(TERTIARY1|T2|T3)\b|\b(TERTIARY1|T2|T3)\W+(?:\w+\W+){0,20}(SECONDARY1|S2|S3)\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}