const regex = /(.*\/).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\\/).*', 'g')
const str = `Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);