re = /(.*\/).*/
str = 'Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result