import Foundation
let pattern = #"(.*\/).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)