#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^AEIOU]$"
Local $sString = "A" & @CRLF & _
"B" & @CRLF & _
"C" & @CRLF & _
"D" & @CRLF & _
"E" & @CRLF & _
"F" & @CRLF & _
"G" & @CRLF & _
"H" & @CRLF & _
"I" & @CRLF & _
"J" & @CRLF & _
"K" & @CRLF & _
"L" & @CRLF & _
"M" & @CRLF & _
"N" & @CRLF & _
"O" & @CRLF & _
"P" & @CRLF & _
"Q" & @CRLF & _
"R" & @CRLF & _
"S" & @CRLF & _
"T" & @CRLF & _
"U" & @CRLF & _
"V" & @CRLF & _
"W" & @CRLF & _
"X" & @CRLF & _
"Y" & @CRLF & _
"Z" & @CRLF & _
" " & @CRLF & _
"!" & @CRLF & _
"?" & @CRLF & _
"7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")