const regex = /[^a-zA-Za-åa-ö 0-9/%!\"#¤%&/()=?\¨'\[\]@£$|§_<>.,-]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Za-åa-ö 0-9\/%!\\"#¤%&\/()=?\\¨\'\\[\\]@£$|§_<>.,-]', 'g')
const str = ` 31.10.2012 20940,00 Sociallnämnden Gullbergs Plåtslageri Automatkonterade överföringar Specsavers / Aqua Drop 1X10ml˜Bottle - Pack of 12`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);