#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|[[:space:]]+)\(?[Oo.'>xX-](?:_*|[.o]+)[-Xx<'.oO]\'?\)?(?:$|[[:space:]]+)"
Local $sString = "-________-'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")