$re = '/(?:^|[[:space:]]+)\(?[Oo.\'>xX-](?:_*|[.o]+)[-Xx<\'.oO]\'?\)?(?:$|[[:space:]]+)/';
$str = '-________-\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);