re = /\/(?!index\.html).+/
str = '/foo
/foo/bar
/index
/index.html
bob
/foo/bar/foo1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end