use strict;
my $str = 'abc§\\ndef§\\nghi\\n
abc§\\ndef§\\nghi§\\n
abc§\\ndef§\\nghi§§\\n';
my $regex = qr/(.*?)§\\n(?=.*\\n)/up;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";