re = /(.*?)§\\n(?=.*\\n)/
str = 'abc§\\ndef§\\nghi\\n
abc§\\ndef§\\nghi§\\n
abc§\\ndef§\\nghi§§\\n'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result