$re = '/#([0-9A-Fa-f])([0-9A-Fa-f])((?=\2)\1|(?:\1\2){2})\b/';
$str = '#EEEEEE
#AAA
#EFE
#333333
#00006d
#123456
#ABABAB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);