import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4})-(\\d{2})-(\\d{1,2}) (\\d{2}):(\\d{2}):(\\d{2}).(\\d{3})";
final String string = "2021-08-21 16:21:00.000\n"
+ "2021-08-1 16:21:00.000\n"
+ "2021-08-8 16:21:00.000";
final String subst = "Year: $1 Month: $2 Day: $3 Hour: $4 Minutes: $5 Seconds: $6 Millis: $7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}