Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?ix) (\w+)\ (semaine|jours)? | (demain|ce soir|aujourd'hui| (next|this)[\ \b](matin|après-midi|soir|Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche) )|(Lundi|Mardi|Mercredi|Jeudi|Vendredi|Samedi|Dimanche) | (janvier|février|Mars|Avril|Mai|Juin|Juillet|Août|Septembre|Octobre|Novembre|Décembre)\ (\w+)((\s|\-)?\w*)
"
g
Input 1
1
New
quelle sera la température dans cinq jours c'est quoi la température pour aujourd'hui Comment fera-t-il lundi prochain? quelle est la température ce soir? donne-moi la température pour demain matin quelle sera la température dans 8 semaines température cet après-midi température lundi prochain What is the weather for march 8 What is the weather for march twenty-second