$re = '/^(?=.*?\bcat\b)(?!.*?\bdog\b).*$/m';
$str = 'My pet: parrot
My pet: dog and cat
My pet: cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);