$re = '/(?:([a-zA-Z]+)(?=[^a-zA-Z]+|$)|(\d+)(?=[^\d]+|$))/';
$str = '1a1 a1a sd435 a gar ad ha5y a456 a45 afg adfgadfg adfg45 a5 a gh a56456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);