using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)";
string substitution = @"$1log.error";
string input = @"catch (Exception e)
{
log.debug(""word"");
//stuff
log.debug(""word2"");
}
function (Exception e)
{
log.debug(""word"");
//stuff
log.debug(""word2"");
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}