$re = '~(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)~';
$str = 'catch (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}
function (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}';
$subst = "$1log.error";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;