import Foundation
let pattern = #"(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
catch (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}
function (Exception e)
{
log.debug("word");
//stuff
log.debug("word2");
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1log.error"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)