using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ""[^""\\]*(?s:\\.[^""\\]*)*+""
(*SKIP)(*F)
|
/
(?:
/ .*
|
\* [^*]* (?: \*+(?!/) [^*]* )*+ (?:\*/)?
)";
string input = @"/* toto****to ****/ /****/
char * foo = ""//don't\"" // remove"" "" // really please don't""; // But remove this ha ha! // along with this!
char *bad_regex_strategy = ""\""good luck\"" // \""counting the \""quotes\"" ""//\""//""; // \""ha"""" \"" "" \"" ha ha\"" ha /// ""\;""ha'
/*
and then imagine a copy of that entire line commented out on the next line of source.
I'd question the entire task and see if there isn't a C source manipulation library you should be using instead. ?
BaseZen 2 hours ago Is it? So when I have the choise between doing this by regex or final state machine, u recommend the FSM, right?
:/ ? user3457394 2 hours ago";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}