re = /(^\s*(?:\+?\d{1,3})?[-. (]*\d{3}[-. )]*\d{3}[-. ]*\d{4}(?: *x(\d+))?\s*)/m
str = 'Contact us via jobsearcher@gmail.com or you can use one of this phones:
754-3010 Local
(541) 754-3010 Domestic
+1-541-754-3010 International
1-541-754-3010 Dialed in the US
001-541-754-3010 Dialed from Germany
191 541 754 3010 Dialed from Franc
636-48018 Local
(089) / 636-48018 Domestic
+49-89-636-48018 International
19-49-89-636-48018 Dialed from France
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end