$re = '/\s*\[\s*\[\s*\[\s*([+-]?\d+)\s*,\s*([+-]?\d+)\s*\]\s*,\s*\[\s*([+-]?\d+)\s*,\s*([+-]?\d+)\s*\]\s*,\s*\[\s*([+-]?\d+)\s*,\s*([+-]?\d+)\s*\]\s*\]\s*\]\s*/m';
$str = '[[[5,3],[2,8],[6,-3]]]
[ [ [ 5 , 3 ] , [ 2 , 8 ] , [ 6 , -3 ] ] ]
[[
[ 5, 3],
[ 2, 8],
[ 6,-3]
]]
[
[
[
5,
3
],
[
2,
8
],
[ 6,
-3
]
]
]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);