// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\[\s*\[\s*\[\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*,\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*\]\s*,\s*\[\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*,\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*\]\s*,\s*\[\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*,\s*([+-]?\d+(\.\d*)?([EeDd][+-]?\d+)?)\s*\]\s*\]\s*\]\s*").unwrap();
let string = "[[[5,3],[2,8],[6,-3]]]
[ [ [ 5.23 , 3.42 ] , [ 2. , 8.17 ] , [ 6 , -3 ] ] ]
[[
[ 5, 3],
[ 2, 8.43],
[ -6.18,-3]
]]
[
[
[
5,
3.141592653
],
[
2.718281828,
8
],
[ 0.618,
-35.16e-17
]
]
]
";
let substitution = "{\"\\1,\\4\",\"\\7,\\10\",\"\\13,\\16\"}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}