$re = '/(\w+(?: \([^\)]*\))?)/';
$str = 'foo (foo, foofoo), bar (foobar), foo, bar (barbar, foo), bar, foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);