using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z\d""._-]{3,128})
(@)
([^-]
[a-z\d_-]*?
[^-]
\.
[^-]
[a-z\d_-]*?
[^-])$";
string input = @"azazaza@f4.f";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}