import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z\\d\"._-]{3,128})\n"
+ "(@)\n"
+ "([^-]\n"
+ "[a-z\\d_-]*?\n"
+ "[^-]\n"
+ "\\.\n"
+ "[^-]\n"
+ "[a-z\\d_-]*?\n"
+ "[^-])$";
final String string = "azazaza@f4.f";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}