const regex = new RegExp('^([a-z\\d"._-]{3,128})
(@)
([^-]
[a-z\\d_-]*?
[^-]
\\.
[^-]
[a-z\\d_-]*?
[^-])$', '')
const str = `azazaza@f4.f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}