package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z]{5}.\d{4}`)
var str = `Identified Outlier
AOJan.2002 0.346
AOJun.2002 0.58979
AAFeb.2002 0.58972`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}