$re = '/[A-Za-z]{5}.\d{4}/m';
$str = 'Identified Outlier
AOJan.2002 0.346
AOJun.2002 0.58979
AAFeb.2002 0.58972';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);