using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^a\n|\G(?<!\A))\n*\Kb$";
string substitution = @"c";
string input = @"b
a
b
b
c
b
a
b
b
b
a
c
b
a
b
a
c
c
d
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}