use strict;
my $str = 'b
a
b
b
c
b
a
b
b
b
a
c
b
a
b
a
c
c
d
';
my $regex = qr/(?:^a\n|\G(?<!\A))\n*\Kb$/mp;
my $subst = 'c';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";