import Foundation
let pattern = #"(?:^a\n|\G(?<!\A))\n*\Kb$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
b
a
b
b
c
b
a
b
b
b
a
c
b
a
b
a
c
c
d
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"c"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)