// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http(?:s?):\/\/(?:www\.)?youtu(?:be\.com\/watch\?v=|\.be\/|.*\&v\=|.*\/embed\/)([\w\-]+)").unwrap();
let string = "http://www.youtube.com/watch?v=a4tU7tkl6n8
https://www.youtube.com/watch?v=a4tU7tkl6n8&autoplay=1
https://www.youtube.com/watch?t=12&v=a4tU7tkl6n8&autoplay=1
https://youtu.be/a4tU7tkl6n8
https://www.youtube-nocookie.com/embed/a4tU7tkl6n8
https://www.youtube.com/embed/a4tU7tkl6n8
https://www.youtube.com/embed/a4tU7tkl6n8?autoplay=1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}