#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(I|me)\b"
Local $sString = "I like candy"
Local $sSubst = "You"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)