use strict;
my $str = 'I like candy';
my $regex = qr/\b(I|me)\b/p;
my $subst = 'You';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";