// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(I|me)\b").unwrap();
let string = "I like candy";
let substitution = "You";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}